Flasher Basher

Please note that the Flash 8 player is required to play Flasher Basher. If you don’t see the game above, please visit Macromedia to update your current version of the Flash Player. We understand the Flash 8 player is currently only available for certain platforms, and we apologize for excluding anyone (Linux users, for instance) with this release. Please contact Adobe/Macromedia with any concerns about Flash 8 availability.

Meanwhile, we hope you enjoy the game!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>